Emprar referències relatives i absolutes a funcions

Com ja s’ha dit, a les fórmules relacionareu valors constants o referències a cel.les.

Introduireu determinats valors o els noms de les cel.les que contenen els arguments sobre els quals fareu els càlculs. També podeu fer càlculs amb un rang de cel.les com a argument.

La forma en què el programa interpreta les referències a cel.la depèn del tipus de referència que feu servir. N´hi ha de diversos tipus. Ara veureu com utilitzar les referències relatives i absolutes.

  • Referències relatives: Cada cel.la s’identifica per la lletra de la columna i el nombre de la fila. Quan en una fórmula introduïu aquest nom, per exemple "B7", el programa de càlcul de "Google Docs" no llegeix directament el valor de la cel.la sinó que ho fa en relació a la posició relativa que estem indicant.

Per exemple, si “B7” conté la següent fórmula "=SUMA(B5+B6)", quan l’arrossegueu o copieu i enganxeu a la cel.la “C7” la fórmula queda modificada automàticament i mostra un nou resultat per a “=SUMA(C5+C6)"

  • Referències absolutes:

Si voleu que el programa de càlcul de "Google Docs" llegeixi un valor en una cel.la sense que canviï quan l’arrossegueu, heu d’emprar referències absolutes. Per fer-ho, poseu el signe $ davant dels caràcters identificadors de la fila i la columna. En el cas anterior la fórmula a la cel.la "B7" es mantindria "=SUMA($B$5:$B$6)"

També podeu utilitzar referències mixtes, combinant els dos tipus de referències. Podeu mantenir fixa la columna però no la fila, o a la inversa. En aquest cas, el resultat també serà diferent quan arrossegueu o copieu la cel.la.

Quan en una cel.la voleu reflectir el valor alfanumèric d’una altra continguda en un full de càlcul diferent a l’actiu, heu d’escriure el nom del full seguit del signe d’admiració i el nom de la cel.la de l’altre full. Per exemple:

Si el valor és numèric, ho fareu posant entre cometes el nom del full. Per exemple: