Emprar referències relatives i absolutes a funcions

Com ja s’ha dit, a les fórmules relacionarem valors constants o referències a cel·les, introduint-hi aquests valors, noms de cel·la o rangs per tal que l'Excel cerqui les dades per fer el càlcul .

La forma en què el programa interpreta les referències a cel·la depèn del tipus de referència que feu servir. Hi ha diversos tipus. Ara veureu com utilitzar les referències relatives i absolutes.

  • Referències relatives: Cada cel·la s’identifica per la lletra de la columna i el nombre de la fila. Quan en una fórmula introduïu aquest nom, per exemple "B14", l'Excel no llegeix directament el valor de la cel·la sinó que ho fa en relació a la posició relativa que estem indicant.

Per exemple, si B14 conté la següent fórmula "=SUMA(B12:B13)", quan l’arrossegueu o copieu i enganxeu a la cel·la C14 la fórmula queda modificada automàticament i mostra el resultat de la fórmula "=SUMA(C12:C13)" :

  • Referències absolutes:

Si voleu que l'Excel llegeixi un valor en una cel·la sense que canviï quan l’arrossegueu, heu d’emprar referències absolutes. Per fer-ho, poseu el signe $ davant dels caràcters identificadors de la fila i la columna. En el cas anterior la fórmula a la cel·la "B14" seria "=SUMA($B$12:$B$13)"

També podeu utilitzar referències mixtes, combinant els dos tipus de referències. Podeu mantenir fixa la columna però no la fila, o a la inversa. En aquest cas, el resultat també serà diferent quan arrossegueu o copieu la cel·la.