Número mixt

Presentació gràfica de l'activitat


Funcions que es faran servir en aquesta activitat:


Objectiu de l'activitat
Expressar el número mixte d'una fracció impròpia.

Desenvolupament de l'activitat:
Desenvolupament de l'activitat:
1. Obrir el fitxer M3 i afegir un nou full anomenant-lo M3P6 número mixt
2. Escriure a la cel·la J6: =SI(A1=0;ALEATENTRE(4;20))
3. Escriure a la cel·la J8: =SI(A1=0;ALEATENTRE(2;J6-1))
4. escriure a la cel·la L6: =QUOCIENT(J6;J8)
5. escriure a la cel·la M6: =SI(MOD(J6;J8)=0;"";MOD(J6;J8))
6. Escriure a la cel·la M8: =SI(MOD(J6;J8)=0;"";J8)

El que ve a continuació serveix per donar una alternativa en cas que el residu de dividir J6 entre J8 sigui 0.
7. Escriure a la cel·la J10: =SI(M6="";ALEATENTRE(20;25);"")
8. Escriure a la cel·la J12: =SI(M8="";ALEATENTRE(15;19);"")
9. Escriure a la cel·la L10: =SI(J10="";"";QUOCIENT(J10;J12))
10. Escriure a la cel·la M10: =SI(J10="";"";SI(MOD(J10;J12)=0;"";MOD(J10;J12)))
11. Escriure a la cel·la M12: =SI(J12="";"";SI(MOD(J10;J12)=0;"";J12))
12. Escriure a la cel·la H6: =SI( (D6&E6&E8)=(L6&M6&M8);"bé";"no")
13. Escriure a la cel·la H8: =SI( (D6&E6&E8)=(L10&M10&M12);"bé";"no")
14. Escriure a la cel·la G6: =SI(O(D6="";E6="";E8="");"";SI(M6="";H8;H6))
15. Escriure a la cel·la B6: =SI(M6="";J10;J6)
16. Escriure a la cel·la B8: =SI(M6="";J12;J8)
17. Fer que l'alçada de la fila 7 sigui de: 1 mm
18. Fer que el color de fons de les cel·les B7 i E7 siguin de color negre.
19. Fusionar les cel·les D6, D7 i D8 i fer que tinguin un color igual al que es veu en el gràfic de la presentació de l'actvitat.
20. Fer que les cel·les E6 i E8 tinguin el color igual al que es veu en el gràfic de la presentació de l'activitat.
21. Fer una macro amb les següent funcions:

  • Esborrar el contingut de les cel·les: D6, E6 i E8
  • Canviar els números de la fracció.
  • Que la cel·la D6 rebi el focus.

22. Protegir, validar i fer no visible les cel·les que convingui.
23. Comprovar que funcioni correctament l'activitat.